summaryrefslogtreecommitdiffstats
path: root/mmc_updater/src/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2013-12-28 02:03:53 +0100
committerPetr Mrázek <peterix@gmail.com>2013-12-28 04:23:48 +0100
commit7652b3d64a63c587f520633364412345083210d4 (patch)
tree12d98c301aa931f20aee0875242bc762cf4d22d1 /mmc_updater/src/tests/CMakeLists.txt
parent30d4f5981d3220386bd320534048594fc364d0e9 (diff)
downloadMultiMC-7652b3d64a63c587f520633364412345083210d4.tar
MultiMC-7652b3d64a63c587f520633364412345083210d4.tar.gz
MultiMC-7652b3d64a63c587f520633364412345083210d4.tar.lz
MultiMC-7652b3d64a63c587f520633364412345083210d4.tar.xz
MultiMC-7652b3d64a63c587f520633364412345083210d4.zip
Various updater fixes
Updater tests for path utils The updater now doesn't use splitpath on Windows (fixes problems with Windows XP) Fix up paths for the OSX updater - should now install the updates into the right place Fix translations install path - translation isntall and deploy should be fixed
Diffstat (limited to 'mmc_updater/src/tests/CMakeLists.txt')
-rw-r--r--mmc_updater/src/tests/CMakeLists.txt19
1 files changed, 12 insertions, 7 deletions
diff --git a/mmc_updater/src/tests/CMakeLists.txt b/mmc_updater/src/tests/CMakeLists.txt
index 1d62214e..79402245 100644
--- a/mmc_updater/src/tests/CMakeLists.txt
+++ b/mmc_updater/src/tests/CMakeLists.txt
@@ -29,13 +29,18 @@ endforeach()
# Add unit test binaries
macro(ADD_UPDATER_TEST CLASS)
- set(TEST_TARGET updater_${CLASS})
- add_executable(${TEST_TARGET} ${CLASS}.cpp)
- target_link_libraries(${TEST_TARGET} updatershared)
- add_test(NAME ${TEST_TARGET} COMMAND ${TEST_TARGET})
- if (APPLE)
- set_target_properties(${TEST_TARGET} PROPERTIES LINK_FLAGS "-framework Security -framework Cocoa")
- endif()
+ set(TEST_TARGET updater_${CLASS})
+ unset(srcs)
+ list(APPEND srcs ${CLASS}.cpp)
+ if (WIN32)
+ list(APPEND srcs ${CMAKE_CURRENT_SOURCE_DIR}/test.rc)
+ endif()
+ add_executable(${TEST_TARGET} ${srcs})
+ target_link_libraries(${TEST_TARGET} updatershared)
+ add_test(NAME ${TEST_TARGET} COMMAND ${TEST_TARGET})
+ if (APPLE)
+ set_target_properties(${TEST_TARGET} PROPERTIES LINK_FLAGS "-framework Security -framework Cocoa")
+ endif()
endmacro()
add_updater_test(TestParseScript)