summaryrefslogtreecommitdiffstats
path: root/mmc_updater/depends/tinyxml/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2013-12-10 07:22:22 +0100
committerPetr Mrázek <peterix@gmail.com>2013-12-10 07:22:22 +0100
commitaa61bbe9e414648399aff2802df5b587dee1a084 (patch)
treeff7809bea445bb76c9fd27a3245e1b2cb7c72596 /mmc_updater/depends/tinyxml/CMakeLists.txt
parent3f5c46a1c4b27e82976e0067e4ec2d6abfffd9ba (diff)
parent712b87c643bbd7bc4ed2cfd459d0b9fdb69e5f0d (diff)
downloadMultiMC-aa61bbe9e414648399aff2802df5b587dee1a084.tar
MultiMC-aa61bbe9e414648399aff2802df5b587dee1a084.tar.gz
MultiMC-aa61bbe9e414648399aff2802df5b587dee1a084.tar.lz
MultiMC-aa61bbe9e414648399aff2802df5b587dee1a084.tar.xz
MultiMC-aa61bbe9e414648399aff2802df5b587dee1a084.zip
Merge branch 'develop' of github.com:MultiMC/MultiMC5 into develop
Conflicts: CMakeLists.txt gui/MainWindow.cpp
Diffstat (limited to 'mmc_updater/depends/tinyxml/CMakeLists.txt')
-rw-r--r--mmc_updater/depends/tinyxml/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/mmc_updater/depends/tinyxml/CMakeLists.txt b/mmc_updater/depends/tinyxml/CMakeLists.txt
new file mode 100644
index 00000000..25c9bb92
--- /dev/null
+++ b/mmc_updater/depends/tinyxml/CMakeLists.txt
@@ -0,0 +1,24 @@
+# TinyXML 1.0.1
+project(tinyxml)
+
+cmake_minimum_required(VERSION 2.6)
+
+Add_definitions(-DTIXML_USE_STL)
+
+set(SOURCES
+ tinystr.cpp
+ tinyxml.cpp
+ tinyxmlerror.cpp
+ tinyxmlparser.cpp
+)
+
+set(HEADERS
+ tinystr.h
+ tinyxml.h
+)
+
+add_library(tinyxml
+ ${SOURCES}
+ ${HEADERS}
+)
+