summaryrefslogtreecommitdiffstats
path: root/mmc_updater/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2014-04-21 23:33:00 +0200
committerPetr Mrázek <peterix@gmail.com>2014-04-21 23:33:00 +0200
commit9d724e0fe4bfb7b7940f3f0c9719affd22a18722 (patch)
treec73e9566e134d2b78e6f1b8bce3c32159b17675f /mmc_updater/CMakeLists.txt
parenta9dfe6d7ec949954b07facff71ee6023e0ced9ee (diff)
parenta00fb1e8da505768b491e5f4d6266784fb1a27c9 (diff)
downloadMultiMC-9d724e0fe4bfb7b7940f3f0c9719affd22a18722.tar
MultiMC-9d724e0fe4bfb7b7940f3f0c9719affd22a18722.tar.gz
MultiMC-9d724e0fe4bfb7b7940f3f0c9719affd22a18722.tar.lz
MultiMC-9d724e0fe4bfb7b7940f3f0c9719affd22a18722.tar.xz
MultiMC-9d724e0fe4bfb7b7940f3f0c9719affd22a18722.zip
Merge remote-tracking branch 'origin/feature_cmake_style' into develop
Conflicts: CMakeLists.txt
Diffstat (limited to 'mmc_updater/CMakeLists.txt')
-rw-r--r--mmc_updater/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/mmc_updater/CMakeLists.txt b/mmc_updater/CMakeLists.txt
index 971ac153..84bc63a5 100644
--- a/mmc_updater/CMakeLists.txt
+++ b/mmc_updater/CMakeLists.txt
@@ -6,18 +6,18 @@ set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules")
include_directories(depends)
-if (WIN32)
- include_directories(depends/win32cpp)
+if(WIN32)
+ include_directories(depends/win32cpp)
# static all the things. The updater must have no dependencies, or it will fail.
- if (MINGW)
+ if(MINGW)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -static-libgcc -static")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -static-libgcc -static-libstdc++ -static")
#set(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "${CMAKE_SHARED_LIBRARY_LINK_C_FLAGS} -static-libgcc -s")
#set(CMAKE_SHARED_LIBRARY_LINK_CXX_FLAGS "${CMAKE_SHARED_LIBRARY_LINK_CXX_FLAGS} -static-libgcc -static-libstdc++ -s")
endif()
- if(MSVC)
+ if(MSVC)
# - Link the updater binary statically with the Visual C++ runtime
# so that the executable can function standalone.
# - Enable PDB generation for release builds
@@ -27,14 +27,14 @@ if (WIN32)
set(CMAKE_CXX_FLAGS_RELEASE "/MT /Zi /O2 /Ob2 /D NDEBUG")
set(CMAKE_C_FLAGS_RELEASE "/MT /Zi /O2 /Ob2 /D NDEBUG")
remove_definitions(-DUNICODE -D_UNICODE)
- endif()
+ endif()
else()
# optimize for reduced code size
set(CMAKE_CXX_FLAGS_RELEASE "-Os")
set(CMAKE_C_FLAGS_RELEASE "-Os")
endif()
-if (APPLE)
+if(APPLE)
# Build the updater as a dual 32/64bit binary. If only one architecture
# is required, removing the other architecture will reduce the size
# of the updater binary