summaryrefslogtreecommitdiffstats
path: root/mmc_updater/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Dalheimer <jan@dalheimer.de>2014-04-06 19:43:09 +0200
committerJan Dalheimer <jan@dalheimer.de>2014-04-06 19:43:09 +0200
commitdd7b6642a3b171734126b6b4a14236cfe6406fcf (patch)
tree6afd61aa059371fffc52bd6f3eb6f6b240e5a4e2 /mmc_updater/CMakeLists.txt
parent482ad250a4454d993a98488edfe01d7f9dc35de7 (diff)
downloadMultiMC-dd7b6642a3b171734126b6b4a14236cfe6406fcf.tar
MultiMC-dd7b6642a3b171734126b6b4a14236cfe6406fcf.tar.gz
MultiMC-dd7b6642a3b171734126b6b4a14236cfe6406fcf.tar.lz
MultiMC-dd7b6642a3b171734126b6b4a14236cfe6406fcf.tar.xz
MultiMC-dd7b6642a3b171734126b6b4a14236cfe6406fcf.zip
Use the same style of CMake files everywhere
Diffstat (limited to 'mmc_updater/CMakeLists.txt')
-rw-r--r--mmc_updater/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/mmc_updater/CMakeLists.txt b/mmc_updater/CMakeLists.txt
index 971ac153..84bc63a5 100644
--- a/mmc_updater/CMakeLists.txt
+++ b/mmc_updater/CMakeLists.txt
@@ -6,18 +6,18 @@ set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules")
include_directories(depends)
-if (WIN32)
- include_directories(depends/win32cpp)
+if(WIN32)
+ include_directories(depends/win32cpp)
# static all the things. The updater must have no dependencies, or it will fail.
- if (MINGW)
+ if(MINGW)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -static-libgcc -static")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -static-libgcc -static-libstdc++ -static")
#set(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "${CMAKE_SHARED_LIBRARY_LINK_C_FLAGS} -static-libgcc -s")
#set(CMAKE_SHARED_LIBRARY_LINK_CXX_FLAGS "${CMAKE_SHARED_LIBRARY_LINK_CXX_FLAGS} -static-libgcc -static-libstdc++ -s")
endif()
- if(MSVC)
+ if(MSVC)
# - Link the updater binary statically with the Visual C++ runtime
# so that the executable can function standalone.
# - Enable PDB generation for release builds
@@ -27,14 +27,14 @@ if (WIN32)
set(CMAKE_CXX_FLAGS_RELEASE "/MT /Zi /O2 /Ob2 /D NDEBUG")
set(CMAKE_C_FLAGS_RELEASE "/MT /Zi /O2 /Ob2 /D NDEBUG")
remove_definitions(-DUNICODE -D_UNICODE)
- endif()
+ endif()
else()
# optimize for reduced code size
set(CMAKE_CXX_FLAGS_RELEASE "-Os")
set(CMAKE_C_FLAGS_RELEASE "-Os")
endif()
-if (APPLE)
+if(APPLE)
# Build the updater as a dual 32/64bit binary. If only one architecture
# is required, removing the other architecture will reduce the size
# of the updater binary