summaryrefslogtreecommitdiffstats
path: root/logic/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2015-07-21 02:38:15 +0200
committerPetr Mrázek <peterix@gmail.com>2015-07-21 02:38:15 +0200
commit61c5a67777a6f7639c9d2f36b14f7a903bdfc5a0 (patch)
treece1e124a44f48d221d40c5534e438ef60491831c /logic/CMakeLists.txt
parent8e7caf4e25dc3f56877a504c45d157860215496b (diff)
downloadMultiMC-61c5a67777a6f7639c9d2f36b14f7a903bdfc5a0.tar
MultiMC-61c5a67777a6f7639c9d2f36b14f7a903bdfc5a0.tar.gz
MultiMC-61c5a67777a6f7639c9d2f36b14f7a903bdfc5a0.tar.lz
MultiMC-61c5a67777a6f7639c9d2f36b14f7a903bdfc5a0.tar.xz
MultiMC-61c5a67777a6f7639c9d2f36b14f7a903bdfc5a0.zip
GH-1053 explode launch task into many small steps, each a Task
Diffstat (limited to 'logic/CMakeLists.txt')
-rw-r--r--logic/CMakeLists.txt22
1 files changed, 19 insertions, 3 deletions
diff --git a/logic/CMakeLists.txt b/logic/CMakeLists.txt
index 53715fa6..7afc0213 100644
--- a/logic/CMakeLists.txt
+++ b/logic/CMakeLists.txt
@@ -93,12 +93,28 @@ set(LOGIC_SOURCES
auth/flows/ValidateTask.cpp
# Game launch logic
- launch/LoggedProcess.h
+ launch/steps/CheckJava.cpp
+ launch/steps/CheckJava.h
+ launch/steps/LaunchCommand.cpp
+ launch/steps/LaunchCommand.h
+ launch/steps/ModMinecraftJar.cpp
+ launch/steps/ModMinecraftJar.h
+ launch/steps/PostLaunchCommand.cpp
+ launch/steps/PostLaunchCommand.h
+ launch/steps/PreLaunchCommand.cpp
+ launch/steps/PreLaunchCommand.h
+ launch/steps/TextPrint.cpp
+ launch/steps/TextPrint.h
+ launch/steps/Update.cpp
+ launch/steps/Update.h
+ launch/LaunchStep.cpp
+ launch/LaunchStep.h
+ launch/LaunchTask.cpp
+ launch/LaunchTask.h
launch/LoggedProcess.cpp
+ launch/LoggedProcess.h
launch/MessageLevel.cpp
launch/MessageLevel.h
- launch/LaunchTask.h
- launch/LaunchTask.cpp
# Update system
updater/GoUpdate.h