summaryrefslogtreecommitdiffstats
path: root/logic/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Dalheimer <jan@dalheimer.de>2015-05-28 19:38:29 +0200
committerPetr Mrázek <peterix@gmail.com>2015-06-06 21:23:05 +0200
commit3a8b238052163952831fb5924b2483a375e86ebd (patch)
treeab120b4fac3a5345a20e7a09e1e7477e67d9ed6f /logic/CMakeLists.txt
parent161dc66c2c8d5f973ee69dab36c3969a7efd7495 (diff)
downloadMultiMC-3a8b238052163952831fb5924b2483a375e86ebd.tar
MultiMC-3a8b238052163952831fb5924b2483a375e86ebd.tar.gz
MultiMC-3a8b238052163952831fb5924b2483a375e86ebd.tar.lz
MultiMC-3a8b238052163952831fb5924b2483a375e86ebd.tar.xz
MultiMC-3a8b238052163952831fb5924b2483a375e86ebd.zip
NOISSUE Various changes from multiauth that are unrelated to it
Diffstat (limited to 'logic/CMakeLists.txt')
-rw-r--r--logic/CMakeLists.txt30
1 files changed, 26 insertions, 4 deletions
diff --git a/logic/CMakeLists.txt b/logic/CMakeLists.txt
index de1940ad..d91fc694 100644
--- a/logic/CMakeLists.txt
+++ b/logic/CMakeLists.txt
@@ -1,6 +1,6 @@
project(MultiMC-Logic)
-SET(LOGIC_SOURCES
+set(LOGIC_SOURCES
# LOGIC - Base classes and infrastructure
BaseInstaller.h
BaseInstaller.cpp
@@ -14,11 +14,14 @@ SET(LOGIC_SOURCES
BaseInstance.h
BaseInstance.cpp
NullInstance.h
- MMCError.h
MMCZip.h
MMCZip.cpp
MMCStrings.h
MMCStrings.cpp
+ BaseConfigObject.h
+ BaseConfigObject.cpp
+ AbstractCommonModel.h
+ AbstractCommonModel.cpp
# Prefix tree where node names are strings between separators
SeparatorPrefixTree.h
@@ -28,8 +31,11 @@ SET(LOGIC_SOURCES
Env.cpp
# JSON parsing helpers
- MMCJson.h
- MMCJson.cpp
+ Json.h
+ Json.cpp
+ FileSystem.h
+ FileSystem.cpp
+ Exception.h
# RW lock protected map
RWStorage.h
@@ -40,6 +46,20 @@ SET(LOGIC_SOURCES
# a smart pointer wrapper intended for safer use with Qt signal/slot mechanisms
QObjectPtr.h
+ # Resources
+ resources/IconResourceHandler.cpp
+ resources/IconResourceHandler.h
+ resources/Resource.cpp
+ resources/Resource.h
+ resources/ResourceHandler.cpp
+ resources/ResourceHandler.h
+ resources/ResourceObserver.cpp
+ resources/ResourceObserver.h
+ resources/WebResourceHandler.cpp
+ resources/WebResourceHandler.h
+ resources/ResourceProxyModel.h
+ resources/ResourceProxyModel.cpp
+
# network stuffs
net/NetAction.h
net/MD5EtagDownload.h
@@ -183,6 +203,8 @@ SET(LOGIC_SOURCES
tasks/ThreadTask.cpp
tasks/SequentialTask.h
tasks/SequentialTask.cpp
+ tasks/StandardTask.h
+ tasks/StandardTask.cpp
# Settings
settings/INIFile.cpp