summaryrefslogtreecommitdiffstats
path: root/libraries/hoedown/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2016-04-10 15:53:05 +0200
committerPetr Mrázek <peterix@gmail.com>2016-05-01 00:00:14 +0200
commitb6d455a02bd338e9dc0faa09d4d8177ecd8d569a (patch)
tree41982bca1ede50049f2f8c7109dd18edeefde6d0 /libraries/hoedown/CMakeLists.txt
parent47e37635f50c09b4f9a9ee7699e3120bab3e4088 (diff)
downloadMultiMC-b6d455a02bd338e9dc0faa09d4d8177ecd8d569a.tar
MultiMC-b6d455a02bd338e9dc0faa09d4d8177ecd8d569a.tar.gz
MultiMC-b6d455a02bd338e9dc0faa09d4d8177ecd8d569a.tar.lz
MultiMC-b6d455a02bd338e9dc0faa09d4d8177ecd8d569a.tar.xz
MultiMC-b6d455a02bd338e9dc0faa09d4d8177ecd8d569a.zip
NOISSUE reorganize and document libraries
Diffstat (limited to 'libraries/hoedown/CMakeLists.txt')
-rw-r--r--libraries/hoedown/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/libraries/hoedown/CMakeLists.txt b/libraries/hoedown/CMakeLists.txt
new file mode 100644
index 00000000..7902e734
--- /dev/null
+++ b/libraries/hoedown/CMakeLists.txt
@@ -0,0 +1,26 @@
+# hoedown 3.0.2 - https://github.com/hoedown/hoedown/archive/3.0.2.tar.gz
+project(hoedown LANGUAGES C VERSION 3.0.2)
+
+set(HOEDOWN_SOURCES
+include/hoedown/autolink.h
+include/hoedown/buffer.h
+include/hoedown/document.h
+include/hoedown/escape.h
+include/hoedown/html.h
+include/hoedown/stack.h
+include/hoedown/version.h
+src/autolink.c
+src/buffer.c
+src/document.c
+src/escape.c
+src/html.c
+src/html_blocks.c
+src/html_smartypants.c
+src/stack.c
+src/version.c
+)
+
+# Include self.
+add_library(hoedown STATIC ${HOEDOWN_SOURCES})
+
+target_include_directories(hoedown PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}/include)