summaryrefslogtreecommitdiffstats
path: root/libraries/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2016-04-10 04:29:29 +0200
committerPetr Mrázek <peterix@gmail.com>2016-04-30 23:59:23 +0200
commit47e37635f50c09b4f9a9ee7699e3120bab3e4088 (patch)
tree061c2f675fb7e244ebe4b54ef206bfbd615c91f8 /libraries/gui/CMakeLists.txt
parentfcd4a482f759cd58ee319a51082d0146b7e426e2 (diff)
downloadMultiMC-47e37635f50c09b4f9a9ee7699e3120bab3e4088.tar
MultiMC-47e37635f50c09b4f9a9ee7699e3120bab3e4088.tar.gz
MultiMC-47e37635f50c09b4f9a9ee7699e3120bab3e4088.tar.lz
MultiMC-47e37635f50c09b4f9a9ee7699e3120bab3e4088.tar.xz
MultiMC-47e37635f50c09b4f9a9ee7699e3120bab3e4088.zip
NOISSUE split GUI stuff from logic library
Diffstat (limited to 'libraries/gui/CMakeLists.txt')
-rw-r--r--libraries/gui/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/libraries/gui/CMakeLists.txt b/libraries/gui/CMakeLists.txt
new file mode 100644
index 00000000..1551a927
--- /dev/null
+++ b/libraries/gui/CMakeLists.txt
@@ -0,0 +1,28 @@
+project(MultiMC_logic)
+
+set(GUI_SOURCES
+ DesktopServices.h
+ DesktopServices.cpp
+
+ # Icons
+ icons/MMCIcon.h
+ icons/MMCIcon.cpp
+ icons/IconList.h
+ icons/IconList.cpp
+
+ SkinUtils.cpp
+ SkinUtils.h
+)
+################################ COMPILE ################################
+
+add_library(MultiMC_gui SHARED ${GUI_SOURCES})
+set_target_properties(MultiMC_gui PROPERTIES CXX_VISIBILITY_PRESET hidden VISIBILITY_INLINES_HIDDEN 1)
+
+generate_export_header(MultiMC_gui)
+
+# Link
+target_link_libraries(MultiMC_gui iconfix MultiMC_logic)
+qt5_use_modules(MultiMC_gui Gui)
+
+# Mark and export headers
+target_include_directories(MultiMC_gui PUBLIC "${CMAKE_CURRENT_BINARY_DIR}" "${CMAKE_CURRENT_SOURCE_DIR}")