summaryrefslogtreecommitdiffstats
path: root/libgroupview/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2013-03-11 22:19:17 +0100
committerPetr Mrázek <peterix@gmail.com>2013-03-11 22:19:17 +0100
commit46f93311afc9f1e2afc306f63cee0e4f462758e2 (patch)
treecc945d66e6ca5e68c43b354d3f8f6d6e70cf5326 /libgroupview/CMakeLists.txt
parent36396f7c6aca9fcc61c8620e10c31ed2c8999ebd (diff)
downloadMultiMC-46f93311afc9f1e2afc306f63cee0e4f462758e2.tar
MultiMC-46f93311afc9f1e2afc306f63cee0e4f462758e2.tar.gz
MultiMC-46f93311afc9f1e2afc306f63cee0e4f462758e2.tar.lz
MultiMC-46f93311afc9f1e2afc306f63cee0e4f462758e2.tar.xz
MultiMC-46f93311afc9f1e2afc306f63cee0e4f462758e2.zip
Instance view, model, delegate.
Diffstat (limited to 'libgroupview/CMakeLists.txt')
-rw-r--r--libgroupview/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/libgroupview/CMakeLists.txt b/libgroupview/CMakeLists.txt
new file mode 100644
index 00000000..9aa3013b
--- /dev/null
+++ b/libgroupview/CMakeLists.txt
@@ -0,0 +1,41 @@
+project(libGroupView)
+
+set(CMAKE_AUTOMOC ON)
+
+# Find Qt
+find_package(Qt5Core REQUIRED)
+find_package(Qt5Gui REQUIRED)
+
+# Include Qt headers.
+include_directories(${Qt5Base_INCLUDE_DIRS})
+
+SET(LIBGROUPVIEW_HEADERS
+include/libgroupview_config.h
+
+# Public headers
+include/kcategorizedsortfilterproxymodel.h
+include/kcategorizedview.h
+include/kcategorydrawer.h
+
+# Private headers
+src/kcategorizedsortfilterproxymodel_p.h
+src/kcategorizedview_p.h
+)
+
+SET(LIBGROUPVIEW_SOURCES
+src/kcategorizedsortfilterproxymodel.cpp
+src/kcategorizedview.cpp
+src/kcategorydrawer.cpp
+)
+
+# Set the include dir path.
+SET(LIBGROUPVIEW_INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/include" PARENT_SCOPE)
+
+# Include self.
+include_directories(${CMAKE_CURRENT_SOURCE_DIR}/include)
+include_directories(${CMAKE_BINARY_DIR}/include)
+
+add_definitions(-DLIBGROUPVIEW_LIBRARY)
+
+add_library(libGroupView SHARED ${LIBGROUPVIEW_SOURCES} ${LIBGROUPVIEW_HEADERS})
+qt5_use_modules(libGroupView Core Gui)