summaryrefslogtreecommitdiffstats
path: root/depends/util/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2013-08-26 02:53:29 +0200
committerPetr Mrázek <peterix@gmail.com>2013-08-26 02:53:29 +0200
commit00742af3a6f6d25fbd3b3b77744e8f39a8c14c71 (patch)
tree41631a8ec88cbe637f877f74115c961d61ebdea6 /depends/util/CMakeLists.txt
parentc5725d653bbe693148d1a34ddcd82f03fda5e8ff (diff)
downloadMultiMC-00742af3a6f6d25fbd3b3b77744e8f39a8c14c71.tar
MultiMC-00742af3a6f6d25fbd3b3b77744e8f39a8c14c71.tar.gz
MultiMC-00742af3a6f6d25fbd3b3b77744e8f39a8c14c71.tar.lz
MultiMC-00742af3a6f6d25fbd3b3b77744e8f39a8c14c71.tar.xz
MultiMC-00742af3a6f6d25fbd3b3b77744e8f39a8c14c71.zip
OS compatibility and generic cleanup.
Removed bspatch/patchlib Now builds and runs on Windows
Diffstat (limited to 'depends/util/CMakeLists.txt')
-rw-r--r--depends/util/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/depends/util/CMakeLists.txt b/depends/util/CMakeLists.txt
index 86542c43..8e89aa74 100644
--- a/depends/util/CMakeLists.txt
+++ b/depends/util/CMakeLists.txt
@@ -43,8 +43,13 @@ src/cmdutils.cpp
# Set the include dir path.
SET(LIBUTIL_INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/include" PARENT_SCOPE)
+# Static link!
+ADD_DEFINITIONS(-DLIBUTIL_STATIC)
+
add_definitions(-DLIBUTIL_LIBRARY)
+set(CMAKE_POSITION_INDEPENDENT_CODE ON)
+
add_library(libUtil STATIC ${LIBUTIL_SOURCES} ${LIBUTIL_HEADERS})
# qt5_use_modules(libUtil Core Network)
qt5_use_modules(libUtil Core)