summaryrefslogtreecommitdiffstats
path: root/depends/patchlib/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2013-08-17 13:40:51 +0200
committerPetr Mrázek <peterix@gmail.com>2013-08-17 13:40:51 +0200
commit253067c782955380bbf66ac0475dc954375b1ff4 (patch)
treeca97e231fd3a764256d95b5fc8d08fc25ff72161 /depends/patchlib/CMakeLists.txt
parent77e80665422c4e97e2286418ab55e20c4030023b (diff)
downloadMultiMC-253067c782955380bbf66ac0475dc954375b1ff4.tar
MultiMC-253067c782955380bbf66ac0475dc954375b1ff4.tar.gz
MultiMC-253067c782955380bbf66ac0475dc954375b1ff4.tar.lz
MultiMC-253067c782955380bbf66ac0475dc954375b1ff4.tar.xz
MultiMC-253067c782955380bbf66ac0475dc954375b1ff4.zip
Move all the things (YES. Move them.)
Also, implemented some basic modlist logic, to be wired up.
Diffstat (limited to 'depends/patchlib/CMakeLists.txt')
-rw-r--r--depends/patchlib/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/depends/patchlib/CMakeLists.txt b/depends/patchlib/CMakeLists.txt
new file mode 100644
index 00000000..4130e08f
--- /dev/null
+++ b/depends/patchlib/CMakeLists.txt
@@ -0,0 +1,14 @@
+project(patchlib C)
+
+set(SRCS
+blocksort.c
+huffman.c
+crctable.c
+randtable.c
+compress.c
+decompress.c
+bzlib.c
+bspatch.c
+)
+
+add_library(patchlib STATIC ${SRCS})