summaryrefslogtreecommitdiffstats
path: root/depends/launcher/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2013-11-24 06:36:16 +0100
committerPetr Mrázek <peterix@gmail.com>2013-11-24 06:36:16 +0100
commitca297fca79a7b1b96e41ba5abed4956af9383c16 (patch)
tree5c6cf2a486c4015f5e52842acb412e39b8498acd /depends/launcher/CMakeLists.txt
parent4124faf474908e4d79d93b0f624bf8fd81bd9972 (diff)
downloadMultiMC-ca297fca79a7b1b96e41ba5abed4956af9383c16.tar
MultiMC-ca297fca79a7b1b96e41ba5abed4956af9383c16.tar.gz
MultiMC-ca297fca79a7b1b96e41ba5abed4956af9383c16.tar.lz
MultiMC-ca297fca79a7b1b96e41ba5abed4956af9383c16.tar.xz
MultiMC-ca297fca79a7b1b96e41ba5abed4956af9383c16.zip
Prepare for rework of instance launch/update
Added missing licenses Added a Java functionality checker (detects 32/64bit java) Refactor of *Update - no longer based on BaseUpdate, but Task directly Fixed runner script to not derp up on 32bit linux. Could add more detection and error reporting there. Resources are now split into graphics and generated. Generated resources are placed in the build tree and included from there. Used the Java checker in the main settings dialog (TODO: instance settings). Partial support for ${arch}-using libraries - both 32 and 64 variants of ${arch} are downloaded.
Diffstat (limited to 'depends/launcher/CMakeLists.txt')
-rw-r--r--depends/launcher/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/depends/launcher/CMakeLists.txt b/depends/launcher/CMakeLists.txt
index e5402ce7..e91d5bd6 100644
--- a/depends/launcher/CMakeLists.txt
+++ b/depends/launcher/CMakeLists.txt
@@ -1,13 +1,11 @@
cmake_minimum_required(VERSION 2.8.6)
project(launcher Java)
-set(CMAKE_MODULE_PATH "${PROJECT_SOURCE_DIR}")
find_package(Java 1.6 REQUIRED COMPONENTS Development)
-
include(UseJava)
set(CMAKE_JAVA_JAR_ENTRY_POINT MultiMCLauncher)
set(CMAKE_JAVA_COMPILE_FLAGS -target 1.6 -source 1.6 -Xlint:deprecation -Xlint:unchecked)
-set(CMAKE_JAVA_TARGET_OUTPUT_DIR "${PROJECT_SOURCE_DIR}/../../resources")
+#set(CMAKE_JAVA_TARGET_OUTPUT_DIR "${PROJECT_SOURCE_DIR}/../../resources")
set(SRC
MultiMCLauncher.java
@@ -20,4 +18,4 @@ set(SRC
MCFrame.java
)
-add_jar(MultiMCLauncher ${SRC}) \ No newline at end of file
+add_jar(MultiMCLauncher ${SRC})