summaryrefslogtreecommitdiffstats
path: root/depends/groupview/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2013-08-26 02:53:29 +0200
committerPetr Mrázek <peterix@gmail.com>2013-08-26 02:53:29 +0200
commit00742af3a6f6d25fbd3b3b77744e8f39a8c14c71 (patch)
tree41631a8ec88cbe637f877f74115c961d61ebdea6 /depends/groupview/CMakeLists.txt
parentc5725d653bbe693148d1a34ddcd82f03fda5e8ff (diff)
downloadMultiMC-00742af3a6f6d25fbd3b3b77744e8f39a8c14c71.tar
MultiMC-00742af3a6f6d25fbd3b3b77744e8f39a8c14c71.tar.gz
MultiMC-00742af3a6f6d25fbd3b3b77744e8f39a8c14c71.tar.lz
MultiMC-00742af3a6f6d25fbd3b3b77744e8f39a8c14c71.tar.xz
MultiMC-00742af3a6f6d25fbd3b3b77744e8f39a8c14c71.zip
OS compatibility and generic cleanup.
Removed bspatch/patchlib Now builds and runs on Windows
Diffstat (limited to 'depends/groupview/CMakeLists.txt')
-rw-r--r--depends/groupview/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/depends/groupview/CMakeLists.txt b/depends/groupview/CMakeLists.txt
index c3a3dafa..417b1d3a 100644
--- a/depends/groupview/CMakeLists.txt
+++ b/depends/groupview/CMakeLists.txt
@@ -35,7 +35,12 @@ SET(LIBGROUPVIEW_INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/include" PARENT_SCOPE)
include_directories(${CMAKE_CURRENT_SOURCE_DIR}/include)
include_directories(${CMAKE_BINARY_DIR}/include)
+# Static link!
+ADD_DEFINITIONS(-DLIBGROUPVIEW_STATIC)
+
add_definitions(-DLIBGROUPVIEW_LIBRARY)
+set(CMAKE_POSITION_INDEPENDENT_CODE ON)
+
add_library(libGroupView STATIC ${LIBGROUPVIEW_SOURCES} ${LIBGROUPVIEW_HEADERS})
qt5_use_modules(libGroupView Core Widgets)