summaryrefslogtreecommitdiffstats
path: root/application/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2015-10-02 00:12:53 +0200
committerPetr Mrázek <peterix@gmail.com>2015-10-02 00:12:53 +0200
commitae4216de6101db63a1ec7d817852cad2d10863f5 (patch)
tree1a565f4381bad632941f46724ae330ea8355bff0 /application/CMakeLists.txt
parentac8ff8806137d3f6db35afe54b0ef777c40278ef (diff)
downloadMultiMC-ae4216de6101db63a1ec7d817852cad2d10863f5.tar
MultiMC-ae4216de6101db63a1ec7d817852cad2d10863f5.tar.gz
MultiMC-ae4216de6101db63a1ec7d817852cad2d10863f5.tar.lz
MultiMC-ae4216de6101db63a1ec7d817852cad2d10863f5.tar.xz
MultiMC-ae4216de6101db63a1ec7d817852cad2d10863f5.zip
GH-719 implement paste.ee API keys
Diffstat (limited to 'application/CMakeLists.txt')
-rw-r--r--application/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/application/CMakeLists.txt b/application/CMakeLists.txt
index 29012157..fdb27607 100644
--- a/application/CMakeLists.txt
+++ b/application/CMakeLists.txt
@@ -29,6 +29,9 @@ set(MultiMC_UPDATER false CACHE BOOL "Whether or not the update system is enable
# Notification URL
set(MultiMC_NOTIFICATION_URL "" CACHE STRING "URL for checking for notifications.")
+# paste.ee API key
+set(MultiMC_PASTE_EE_API_KEY "" CACHE STRING "API key you can get from paste.ee when you register an account")
+
#### Check the current Git commit
include(GitFunctions)
git_run(COMMAND rev-parse HEAD DEFAULT "Unknown" OUTPUT_VAR MultiMC_GIT_COMMIT)
@@ -199,6 +202,8 @@ SET(MULTIMC_SOURCES
pages/global/MultiMCPage.h
pages/global/ProxyPage.cpp
pages/global/ProxyPage.h
+ pages/global/PasteEEPage.cpp
+ pages/global/PasteEEPage.h
# GUI - dialogs
dialogs/AboutDialog.cpp
@@ -289,6 +294,7 @@ SET(MULTIMC_UIS
pages/global/MinecraftPage.ui
pages/global/MultiMCPage.ui
pages/global/ProxyPage.ui
+ pages/global/PasteEEPage.ui
# Dialogs
dialogs/CopyInstanceDialog.ui