summaryrefslogtreecommitdiffstats
path: root/application/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2017-05-07 22:19:01 +0200
committerPetr Mrázek <peterix@gmail.com>2017-05-07 22:19:01 +0200
commit3fb15e4a4d94263964537a29c8ced87590d889d3 (patch)
tree10f82fbf64b9959510c0b35fcdfd5b79253989cc /application/CMakeLists.txt
parenta379d43d7c6eb6187aa76018b2ada7aa61c77e6f (diff)
downloadMultiMC-3fb15e4a4d94263964537a29c8ced87590d889d3.tar
MultiMC-3fb15e4a4d94263964537a29c8ced87590d889d3.tar.gz
MultiMC-3fb15e4a4d94263964537a29c8ced87590d889d3.tar.lz
MultiMC-3fb15e4a4d94263964537a29c8ced87590d889d3.tar.xz
MultiMC-3fb15e4a4d94263964537a29c8ced87590d889d3.zip
NOISSUE include qt.conf in all bundles again
Looks like it just doesn't work properly without that.
Diffstat (limited to 'application/CMakeLists.txt')
-rw-r--r--application/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/application/CMakeLists.txt b/application/CMakeLists.txt
index 9c20f1d3..5101464b 100644
--- a/application/CMakeLists.txt
+++ b/application/CMakeLists.txt
@@ -351,11 +351,6 @@ if(MultiMC_LAYOUT_REAL STREQUAL "mac-bundle")
# Add the icon
install(FILES resources/MultiMC.icns DESTINATION ${RESOURCES_DEST_DIR})
- # Add qt.conf - because for some reason, an empty file is needed to make things work on macOS
- install(
- CODE "file(WRITE \"\${CMAKE_INSTALL_PREFIX}/${RESOURCES_DEST_DIR}/qt.conf\" \"\")"
- COMPONENT Runtime
- )
elseif(MultiMC_LAYOUT_REAL STREQUAL "lin-bundle")
set(BINARY_DEST_DIR "bin")
set(LIBRARY_DEST_DIR "bin")
@@ -443,7 +438,12 @@ if(NOT INSTALL_BUNDLE)
${LIBRARY_DEST_DIR}
)
else()
- # Bundle stuff
+ # Add qt.conf - this makes Qt stop looking for things outside the bundle
+ install(
+ CODE "file(WRITE \"\${CMAKE_INSTALL_PREFIX}/${RESOURCES_DEST_DIR}/qt.conf\" \"\")"
+ COMPONENT Runtime
+ )
+ # Bundle plugins
if(CMAKE_BUILD_TYPE STREQUAL "Debug" OR CMAKE_BUILD_TYPE STREQUAL "RelWithDebInfo")
# Image formats
install(