summaryrefslogtreecommitdiffstats
path: root/application/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2018-02-17 00:00:06 +0100
committerPetr Mrázek <peterix@gmail.com>2018-02-17 00:57:54 +0100
commit65bca654895c94e83ef25008dc1c44cc822cfbab (patch)
tree1ec8ced7e8f9af0f7c39c2407b72f51a05bb366f /application/CMakeLists.txt
parenta7957f24bac2a6c7fea6f5f2fbfcd77b4db16fa8 (diff)
downloadMultiMC-65bca654895c94e83ef25008dc1c44cc822cfbab.tar
MultiMC-65bca654895c94e83ef25008dc1c44cc822cfbab.tar.gz
MultiMC-65bca654895c94e83ef25008dc1c44cc822cfbab.tar.lz
MultiMC-65bca654895c94e83ef25008dc1c44cc822cfbab.tar.xz
MultiMC-65bca654895c94e83ef25008dc1c44cc822cfbab.zip
GH-2150 Split out custom commands into a custom widget
Now it is used from a global page and from a sub-page in the instance settings.
Diffstat (limited to 'application/CMakeLists.txt')
-rw-r--r--application/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/application/CMakeLists.txt b/application/CMakeLists.txt
index aa09efbb..00d93595 100644
--- a/application/CMakeLists.txt
+++ b/application/CMakeLists.txt
@@ -101,6 +101,8 @@ SET(MULTIMC_SOURCES
# GUI - global settings pages
pages/global/AccountListPage.cpp
pages/global/AccountListPage.h
+ pages/global/CustomCommandsPage.cpp
+ pages/global/CustomCommandsPage.h
pages/global/ExternalToolsPage.cpp
pages/global/ExternalToolsPage.h
pages/global/JavaPage.cpp
@@ -155,6 +157,8 @@ SET(MULTIMC_SOURCES
# GUI - widgets
widgets/Common.cpp
widgets/Common.h
+ widgets/CustomCommands.cpp
+ widgets/CustomCommands.h
widgets/FocusLineEdit.cpp
widgets/FocusLineEdit.h
widgets/IconLabel.cpp
@@ -232,6 +236,7 @@ SET(MULTIMC_UIS
dialogs/SkinUploadDialog.ui
# Widgets/other
+ widgets/CustomCommands.ui
widgets/MCModInfoFrame.ui
)