summaryrefslogtreecommitdiffstats
path: root/api/logic/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2017-05-06 17:22:14 +0200
committerPetr Mrázek <peterix@gmail.com>2017-05-06 17:36:57 +0200
commit15c829fd3ce0de04db938566a56e66531c320580 (patch)
tree629ca7ea6d2433a1c6dafdf0c4268ef21f30e7f8 /api/logic/CMakeLists.txt
parent349381cb2b930263dda875945b912b74656fd847 (diff)
downloadMultiMC-15c829fd3ce0de04db938566a56e66531c320580.tar
MultiMC-15c829fd3ce0de04db938566a56e66531c320580.tar.gz
MultiMC-15c829fd3ce0de04db938566a56e66531c320580.tar.lz
MultiMC-15c829fd3ce0de04db938566a56e66531c320580.tar.xz
MultiMC-15c829fd3ce0de04db938566a56e66531c320580.zip
GH-1876 Fork and update quazip
* It is added as a new submodule: https://github.com/MultiMC/quazip/tree/multimc-1 * Its build system has been entirely replaced to remove the existing issues with it * It now has working unit tests * No more patches needed * It has a static linking exception in its license now, but we use it shared anyway
Diffstat (limited to 'api/logic/CMakeLists.txt')
-rw-r--r--api/logic/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/api/logic/CMakeLists.txt b/api/logic/CMakeLists.txt
index 24db362e..2eda34fe 100644
--- a/api/logic/CMakeLists.txt
+++ b/api/logic/CMakeLists.txt
@@ -469,9 +469,8 @@ set_target_properties(MultiMC_logic PROPERTIES CXX_VISIBILITY_PRESET hidden VISI
generate_export_header(MultiMC_logic)
# Link
-target_link_libraries(MultiMC_logic xz-embedded MultiMC_unpack200 systeminfo ${QUAZIP_LIBRARIES} ${NBT_NAME} ${ZLIB_LIBRARIES})
+target_link_libraries(MultiMC_logic xz-embedded MultiMC_unpack200 systeminfo MultiMC_quazip ${NBT_NAME} ${ZLIB_LIBRARIES})
qt5_use_modules(MultiMC_logic Core Xml Network Concurrent)
-add_dependencies(MultiMC_logic QuaZIP)
# Mark and export headers
target_include_directories(MultiMC_logic PUBLIC "${CMAKE_CURRENT_BINARY_DIR}" "${CMAKE_CURRENT_SOURCE_DIR}" PRIVATE "${ZLIB_INCLUDE_DIRS}")