summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSky <git@bunnies.cc>2013-10-06 01:09:21 +0100
committerSky <git@bunnies.cc>2013-10-06 01:09:21 +0100
commitd48aae7a16e8e5f33683f5a498bb5b1edb21dc31 (patch)
treef0b443dae3020629c27207b057ecaa8c819c19f0 /CMakeLists.txt
parent2398acc9e490ce124aa621c19156c89ef87591f1 (diff)
downloadMultiMC-d48aae7a16e8e5f33683f5a498bb5b1edb21dc31.tar
MultiMC-d48aae7a16e8e5f33683f5a498bb5b1edb21dc31.tar.gz
MultiMC-d48aae7a16e8e5f33683f5a498bb5b1edb21dc31.tar.lz
MultiMC-d48aae7a16e8e5f33683f5a498bb5b1edb21dc31.tar.xz
MultiMC-d48aae7a16e8e5f33683f5a498bb5b1edb21dc31.zip
Fix Linux CMake issues arising from Windows workaround
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 267a57d5..73c866bb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,9 @@
cmake_minimum_required(VERSION 2.8.9)
-# In Qt 5.1+ we have our own main() function, don't autolink to qtmain on Windows
-cmake_policy(SET CMP0020 OLD)
+IF(WIN32)
+ # In Qt 5.1+ we have our own main() function, don't autolink to qtmain on Windows
+ cmake_policy(SET CMP0020 OLD)
+ENDIF()
project(MultiMC)