summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOrochimarufan <orochimarufan.x3@gmail.com>2013-02-18 17:08:18 +0100
committerOrochimarufan <orochimarufan.x3@gmail.com>2013-02-18 17:08:18 +0100
commitcf0e78b46dbd740caac9288f3fe5ef5d99ed2ce9 (patch)
tree67af81fe5b013146bd30339eb8902dd513cf88ca /CMakeLists.txt
parent369b1c55c99aa8bdcd2d57ab4aad3633343f1417 (diff)
parentbd0e4b76066505df54d3fa20082196447aa1271a (diff)
downloadMultiMC-cf0e78b46dbd740caac9288f3fe5ef5d99ed2ce9.tar
MultiMC-cf0e78b46dbd740caac9288f3fe5ef5d99ed2ce9.tar.gz
MultiMC-cf0e78b46dbd740caac9288f3fe5ef5d99ed2ce9.tar.lz
MultiMC-cf0e78b46dbd740caac9288f3fe5ef5d99ed2ce9.tar.xz
MultiMC-cf0e78b46dbd740caac9288f3fe5ef5d99ed2ce9.zip
Merge branch 'master' of http://github.com/Forkk/MultiMC5
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 95a16f60..9c8f7090 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,10 +35,16 @@ include_directories(patchlib)
# add the java launcher
add_subdirectory(launcher)
-IF(UNIX)
+IF(APPLE)
+ # assume clang 4.1.0+, add C++0x/C++11 stuff
+ message(STATUS "Using APPLE CMAKE_CXX_FLAGS")
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x -stdlib=libc++")
+ELSEIF(UNIX)
# assume GCC, add C++0x/C++11 stuff
+ message(STATUS "Using UNIX CMAKE_CXX_FLAGS")
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
ELSEIF(MINGW)
+ message(STATUS "Using MINGW CMAKE_CXX_FLAGS")
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=gnu++0x")
ENDIF()