summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2013-09-30 03:29:12 +0200
committerPetr Mrázek <peterix@gmail.com>2013-09-30 03:29:12 +0200
commitc05a39147a462d610dabaf89dae59c004e7dd539 (patch)
tree10cff4a66c8d9999df7e02648b72b1c7a289ada5 /CMakeLists.txt
parent2173abb9a87c67b53e64c9bdebbba5fa6b4d4b7d (diff)
parente45b444242104e557f1bce14e9c11e3792bbe41f (diff)
downloadMultiMC-c05a39147a462d610dabaf89dae59c004e7dd539.tar
MultiMC-c05a39147a462d610dabaf89dae59c004e7dd539.tar.gz
MultiMC-c05a39147a462d610dabaf89dae59c004e7dd539.tar.lz
MultiMC-c05a39147a462d610dabaf89dae59c004e7dd539.tar.xz
MultiMC-c05a39147a462d610dabaf89dae59c004e7dd539.zip
Implemented xz and pack200 unpackers required for proper forge installation.
Merge branch 'feature_forge_unpackers' into develop Conflicts: CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 12 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1a056a08..e5e5e1fa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -50,6 +50,14 @@ include_directories(depends/quazip)
# Add the java launcher
add_subdirectory(depends/launcher)
+# Add xz decompression
+add_subdirectory(depends/xz-embedded)
+include_directories(${XZ_INCLUDE_DIR})
+
+# Add pack200 decompression
+add_subdirectory(depends/pack200)
+include_directories(${PACK200_INCLUDE_DIR})
+
######## MultiMC Libs ########
# Add the util library.
@@ -225,6 +233,8 @@ logic/net/ByteArrayDownload.h
logic/net/ByteArrayDownload.cpp
logic/net/CacheDownload.h
logic/net/CacheDownload.cpp
+logic/net/ForgeXzDownload.h
+logic/net/ForgeXzDownload.cpp
logic/net/DownloadJob.h
logic/net/DownloadJob.cpp
logic/net/HttpMetaCache.h
@@ -347,8 +357,8 @@ ADD_EXECUTABLE(MultiMC MACOSX_BUNDLE WIN32
${MULTIMC_SOURCES} ${MULTIMC_UI} ${MULTIMC_QRC} ${MULTIMC_RCS})
# Link
-QT5_USE_MODULES(MultiMC Widgets Network Xml)
-TARGET_LINK_LIBRARIES(MultiMC quazip libUtil libSettings libGroupView ${MultiMC_LINK_ADDITIONAL_LIBS})
+TARGET_LINK_LIBRARIES(MultiMC xz-embedded unpack200 quazip libUtil libSettings libGroupView ${MultiMC_LINK_ADDITIONAL_LIBS})
+QT5_USE_MODULES(MultiMC Core Widgets Network Xml)
ADD_DEPENDENCIES(MultiMC MultiMCLauncher)
option(BUILD_KEYRING_TEST "Build the simple keyring test binary" OFF)