summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew <forkk@forkk.net>2013-05-17 11:53:22 -0500
committerAndrew <forkk@forkk.net>2013-05-17 11:53:22 -0500
commit3b38e5f92496cb932d14c9a4492292b057d2f431 (patch)
treebc86a942aa6c8b1ef83cfa5bedd2acd089304682 /CMakeLists.txt
parent159404f444316340c7eba3eecfafaa46842f5783 (diff)
downloadMultiMC-3b38e5f92496cb932d14c9a4492292b057d2f431.tar
MultiMC-3b38e5f92496cb932d14c9a4492292b057d2f431.tar.gz
MultiMC-3b38e5f92496cb932d14c9a4492292b057d2f431.tar.lz
MultiMC-3b38e5f92496cb932d14c9a4492292b057d2f431.tar.xz
MultiMC-3b38e5f92496cb932d14c9a4492292b057d2f431.zip
Implemented LWJGL version lists.
The LWJGL list actually doesn't use tasks for loading. Instead, it takes advantage of the QNetworkAccessManager's asynchronous requests. This is a system that I may look to implement for other version lists and things such as the Minecraft version list and possibly even instance mod lists. Loading things this way means that code that wants to load a list can simply call the load list function, rather than having to get a task from the list and execute the task. Unfortunately, it also means we can't have task progress dialogs for loading lists, but it shouldn't really be too difficult to write one that works with this system. At some point in the future, I'll probably end up putting all the code for this method of loading lists into a base class and then update the other lists to support it.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 523d55c9..10308e18 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -173,6 +173,7 @@ gui/consolewindow.h
gui/instancemodel.h
gui/instancedelegate.h
gui/versionselectdialog.h
+gui/lwjglselectdialog.h
gui/iconcache.h
multimc_pragma.h
@@ -203,6 +204,7 @@ gui/consolewindow.cpp
gui/instancemodel.cpp
gui/instancedelegate.cpp
gui/versionselectdialog.cpp
+gui/lwjglselectdialog.cpp
gui/iconcache.cpp
java/javautils.cpp
@@ -222,6 +224,7 @@ gui/browserdialog.ui
gui/aboutdialog.ui
gui/consolewindow.ui
gui/versionselectdialog.ui
+gui/lwjglselectdialog.ui
)