summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2014-03-02 19:12:04 +0100
committerPetr Mrázek <peterix@gmail.com>2014-03-02 19:12:04 +0100
commit28ad9befdcac246eb69a434be970abc29a80bc80 (patch)
tree330451feee32c4163b02132076491ad4fd311e9b /CMakeLists.txt
parent80d146866c8c5f00c6d790b476a774def71010bf (diff)
downloadMultiMC-28ad9befdcac246eb69a434be970abc29a80bc80.tar
MultiMC-28ad9befdcac246eb69a434be970abc29a80bc80.tar.gz
MultiMC-28ad9befdcac246eb69a434be970abc29a80bc80.tar.lz
MultiMC-28ad9befdcac246eb69a434be970abc29a80bc80.tar.xz
MultiMC-28ad9befdcac246eb69a434be970abc29a80bc80.zip
Remove a lot of error code and error handling madness.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 229179cb..d9279bcb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -257,6 +257,7 @@ SET(MULTIMC_SOURCES
MultiMC.h
MultiMC.cpp
MultiMCVersion.h
+MMCError.h
# Logging
logger/QsDebugOutput.cpp
@@ -353,6 +354,10 @@ logic/ModList.cpp
logic/InstanceLauncher.h
logic/InstanceLauncher.cpp
+# JSON parsing helpers
+logic/MMCJson.h
+logic/MMCJson.cpp
+
# network stuffs
logic/net/NetAction.h
logic/net/MD5EtagDownload.h