summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Dalheimer <jan@dalheimer.de>2014-02-25 18:46:50 +0100
committerJan Dalheimer <jan@dalheimer.de>2014-02-25 18:46:50 +0100
commit00f4f533aa6f64582f647fe891c761b311fb1ac3 (patch)
treef598d755f90bb25142ad3c494f4e70b1c8dc6e06 /CMakeLists.txt
parent3133bb3ea0be5a3e0e3688db9fb3077a772f53a0 (diff)
downloadMultiMC-00f4f533aa6f64582f647fe891c761b311fb1ac3.tar
MultiMC-00f4f533aa6f64582f647fe891c761b311fb1ac3.tar.gz
MultiMC-00f4f533aa6f64582f647fe891c761b311fb1ac3.tar.lz
MultiMC-00f4f533aa6f64582f647fe891c761b311fb1ac3.tar.xz
MultiMC-00f4f533aa6f64582f647fe891c761b311fb1ac3.zip
Fix to the way translations are handled. Also updated the german translation with the new strings.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 2 insertions, 18 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 54a4be19..f070684d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -758,24 +758,8 @@ INCLUDE(CPack)
include_directories(${PROJECT_BINARY_DIR}/include)
-### translation stuff
-
-file (GLOB TRANSLATIONS_FILES translations/*.ts)
-
-option (UPDATE_TRANSLATIONS "Update source translation translations/*.ts files (WARNING: make clean will delete the source .ts files! Danger!)")
-IF(UPDATE_TRANSLATIONS)
- qt5_create_translation(QM_FILES ${FILES_TO_TRANSLATE} ${TRANSLATIONS_FILES})
-ELSE()
- qt5_add_translation(QM_FILES ${TRANSLATIONS_FILES})
-ENDIF()
-
-add_custom_target (translations DEPENDS ${QM_FILES})
-IF(APPLE AND UNIX) ## OSX
- install(FILES ${QM_FILES} DESTINATION MultiMC.app/Contents/MacOS/translations)
-ELSE()
- install(FILES ${QM_FILES} DESTINATION translations)
-ENDIF()
-
+# Translations
+add_subdirectory(translations)
# Tests
add_subdirectory(tests)