summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Mrázek <peterix@gmail.com>2014-11-15 23:22:08 +0100
committerPetr Mrázek <peterix@gmail.com>2014-11-15 23:35:24 +0100
commitb7c4284019e1589f343ea7b497d4f5eb1be0556d (patch)
tree5263a94518770ffc327d6fb43487719d7dce4d31 /CMakeLists.txt
parent2315bf7bc518405f6d548250cdfda67fb76b3bb0 (diff)
downloadMultiMC-b7c4284019e1589f343ea7b497d4f5eb1be0556d.tar
MultiMC-b7c4284019e1589f343ea7b497d4f5eb1be0556d.tar.gz
MultiMC-b7c4284019e1589f343ea7b497d4f5eb1be0556d.tar.lz
MultiMC-b7c4284019e1589f343ea7b497d4f5eb1be0556d.tar.xz
MultiMC-b7c4284019e1589f343ea7b497d4f5eb1be0556d.zip
Remove crash handler
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt30
1 files changed, 0 insertions, 30 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 70031bd2..77c4770c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -77,33 +77,9 @@ if(${BIGENDIAN})
add_definitions(-DMULTIMC_BIG_ENDIAN)
endif(${BIGENDIAN})
-
-######## Dark magic crash reports ########
-option(MultiMC_HANDLE_SEGV "Handle fatal crashes and generate crash reports." OFF)
-set(CRASH_HANDLER_IMPL "")
-message(STATUS "Crash dumps are ${MultiMC_HANDLE_SEGV}")
-if (MultiMC_HANDLE_SEGV)
- add_definitions(-DHANDLE_SEGV)
- if (WIN32)
- find_package(DbgHelp)
- set(MultiMC_LINK_ADDITIONAL_LIBS "${MultiMC_LINK_ADDITIONAL_LIBS}dbghelp")
- set(MultiMC_CRASH_HANDLER_EXTRA_H "WinBacktrace.h")
- set(MultiMC_CRASH_HANDLER_EXTRA_CPP "WinBacktrace.cpp")
- endif ()
-endif ()
-
-option(MultiMC_TEST_SEGV "Intentionally segfault sometimes to test crash handling." OFF)
-if (MultiMC_TEST_SEGV)
- # TODO: Make this a unit test instead.
- message(WARNING "You have enabled crash handler testing. MULTIMC WILL INTENTIONALLY CRASH ITSELF. Crashes should occur on exit and when the new instance button is pressed.")
- add_definitions(-DTEST_SEGV)
-endif ()
-
-
######## Set URLs ########
set(MultiMC_NEWS_RSS_URL "http://multimc.org/rss.xml" CACHE STRING "URL to fetch MultiMC's news RSS feed from.")
-
######## Set version numbers ########
set(MultiMC_VERSION_MAJOR 0)
set(MultiMC_VERSION_MINOR 5)
@@ -279,12 +255,6 @@ SET(MULTIMC_SOURCES
BuildConfig.h
${PROJECT_BINARY_DIR}/BuildConfig.cpp
- # Crash handling
- HandleCrash.h
- HandleCrash.cpp
- ${MultiMC_CRASH_HANDLER_EXTRA_H} # Extra platform specific stuff
- ${MultiMC_CRASH_HANDLER_EXTRA_CPP}
-
# Logging
logger/QsDebugOutput.cpp
logger/QsDebugOutput.h