summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5057333..64a9dbe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,6 +13,7 @@ OPTION(WITH_ALSA "Enable ALSA support" ON)
OPTION(WITH_DIAMONDCARD "Enable Diamondcard integration" OFF)
OPTION(WITH_QT4 "Enable Qt 4 GUI" OFF)
OPTION(WITH_QT5 "Enable Qt 5 GUI" OFF)
+OPTION(WITH_G729 "Enable G.729A support (incomplete)" OFF)
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_LIST_DIR}/cmake")
@@ -101,6 +102,20 @@ if (WITH_ILBC)
endif (ILBC_FOUND)
endif (WITH_ILBC)
+if (WITH_G729)
+ find_package(G729)
+
+ if (G729_FOUND)
+ message(STATUS "bcg729 OK")
+ set(HAVE_BCG729 TRUE)
+
+ include_directories(${G729_INCLUDE_DIR})
+ else (G729_FOUND)
+ message(FATAL_ERROR "bcg729 not found!")
+ endif (G729_FOUND)
+endif (WITH_G729)
+
+
check_include_file(unistd.h HAVE_UNISTD_H)
check_include_file(linux/types.h HAVE_LINUX_TYPES_H)
check_include_file(linux/errqueue.h HAVE_LINUX_ERRQUEUE_H)