summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrédéric Brière <fbriere@fbriere.net>2018-02-13 10:29:31 -0500
committerFrédéric Brière <fbriere@fbriere.net>2019-12-29 02:39:51 -0500
commit6952b81fe89a136c0d087aa98cfbfd8bfc965818 (patch)
tree27c95e8e3cf97fae341d7a042ce9d192d17e1155 /CMakeLists.txt
parent5635f7c2483c4ceac5c0e1cf5e522f7be32fd2f1 (diff)
downloadtwinkle-6952b81fe89a136c0d087aa98cfbfd8bfc965818.tar
twinkle-6952b81fe89a136c0d087aa98cfbfd8bfc965818.tar.gz
twinkle-6952b81fe89a136c0d087aa98cfbfd8bfc965818.tar.lz
twinkle-6952b81fe89a136c0d087aa98cfbfd8bfc965818.tar.xz
twinkle-6952b81fe89a136c0d087aa98cfbfd8bfc965818.zip
CMake: Check if libilbc links without 'extern "C"' (ILBC_CPP)
This variable was originally set manually in configure.in.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c20bd16..5e347b1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,6 +88,9 @@ if (WITH_ILBC)
if (ILBC_FOUND)
message(STATUS "iLBC OK")
set(HAVE_ILBC TRUE)
+ if (ILBC_CPP)
+ set(HAVE_ILBC_CPP TRUE)
+ endif (ILBC_CPP)
include_directories(${ILBC_INCLUDE_DIR})
else (ILBC_FOUND)