summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLubos Dolezel <lubos@dolezel.info>2015-06-01 16:38:53 +0200
committerLubos Dolezel <lubos@dolezel.info>2015-06-01 16:38:53 +0200
commit2142a3eaa4c1eb99aa1e4c7d95a4e1115bc4c689 (patch)
treed5e801c683f59a4471ba9d64f2b22ab7908a8b8b /CMakeLists.txt
parent545703d60acb8b0245e3d79e5dfd7171ca10c572 (diff)
downloadtwinkle-2142a3eaa4c1eb99aa1e4c7d95a4e1115bc4c689.tar
twinkle-2142a3eaa4c1eb99aa1e4c7d95a4e1115bc4c689.tar.gz
twinkle-2142a3eaa4c1eb99aa1e4c7d95a4e1115bc4c689.tar.lz
twinkle-2142a3eaa4c1eb99aa1e4c7d95a4e1115bc4c689.tar.xz
twinkle-2142a3eaa4c1eb99aa1e4c7d95a4e1115bc4c689.zip
Many submodules building (no gui yet), with link-time errors
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt65
1 files changed, 65 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f698e29..4ccb7cd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,21 +2,73 @@ project(twinkle)
cmake_minimum_required(VERSION 2.6.0 FATAL_ERROR)
+set(PRODUCT_VERSION "1.9.0")
+set(PRODUCT_DATE "June 1, 2015")
+
OPTION(WITH_ZRTP "Enable ZRTP encrypted calls" OFF)
OPTION(WITH_SPEEX "Enable the Speex codec" OFF)
OPTION(WITH_ILBC "Enable the iLBC codec" OFF)
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_LIST_DIR}/cmake")
+
+include (CheckIncludeFile)
find_package(Qt4 REQUIRED)
+find_package(LibXml2 REQUIRED)
+find_package(ALSA REQUIRED)
+find_package(LibMagic REQUIRED)
+find_package(LibSndfile REQUIRED)
+find_package(Readline REQUIRED)
+#find_package(BISON)
+#find_package(FLEX)
+
+include_directories(${LIBXML2_INCLUDE_DIR})
if (WITH_ZRTP)
find_package(Zrtpcpp)
if (ZRTPCPP_FOUND)
message(STATUS "libzrtpcpp OK")
+
+ include_directories(${ZRTPCPP_INCLUDE_DIR})
else (ZRTPCPP_FOUND)
message(FATAL_ERROR "libzrtpcpp not found!")
endif (ZRTPCPP_FOUND)
+
+ #####
+
+ find_package(Ccrtp)
+
+ if (CCRTP_FOUND)
+ message(STATUS "ccrtp OK")
+
+ include_directories(${CCRTP_INCLUDE_DIR})
+ else (CCRTP_FOUND)
+ message(FATAL_ERROR "ccrtp not found!")
+ endif (CCRTP_FOUND)
+
+ #####
+
+ find_package(Commoncpp)
+
+ if (COMMONCPP_FOUND)
+ message(STATUS "commoncpp OK")
+
+ include_directories(${COMMONCPP_INCLUDE_DIR})
+ else (COMMONCPP_FOUND)
+ message(FATAL_ERROR "commoncpp not found!")
+ endif (COMMONCPP_FOUND)
+
+ #####
+
+ find_package(Ucommon)
+
+ if (UCOMMON_FOUND)
+ message(STATUS "ucommon OK")
+
+ include_directories(${UCOMMON_INCLUDE_DIR})
+ else (UCOMMON_FOUND)
+ message(FATAL_ERROR "ucommon not found!")
+ endif (UCOMMON_FOUND)
endif (WITH_ZRTP)
if (WITH_SPEEX)
@@ -24,6 +76,8 @@ if (WITH_SPEEX)
if (SPEEX_FOUND)
message(STATUS "Speex OK")
+
+ include_directories(${SPEEX_INCLUDE_DIR})
else (SPEEX_FOUND)
message(FATAL_ERROR "Speex not found!")
endif (SPEEX_FOUND)
@@ -34,7 +88,18 @@ if (WITH_ILBC)
if (ILBC_FOUND)
message(STATUS "iLBC OK")
+
+ include_directories(${ILBC_INCLUDE_DIR})
else (ILBC_FOUND)
message(FATAL_ERROR "iLBC not found!")
endif (ILBC_FOUND)
endif (WITH_ILBC)
+
+check_include_file(unistd.h HAVE_UNISTD_H)
+check_include_file(linux/types.h HAVE_LINUX_TYPES_H)
+check_include_file(linux/errqueue.h HAVE_LINUX_ERRQUEUE_H)
+
+configure_file(twinkle_config.h.in twinkle_config.h)
+include_directories("${CMAKE_BINARY_DIR}")
+
+add_subdirectory(src)