summaryrefslogtreecommitdiffstats
path: root/third_party/rust/url/Cargo.toml
diff options
context:
space:
mode:
authorMatt A. Tobin <mattatobin@localhost.localdomain>2018-02-02 04:16:08 -0500
committerMatt A. Tobin <mattatobin@localhost.localdomain>2018-02-02 04:16:08 -0500
commit5f8de423f190bbb79a62f804151bc24824fa32d8 (patch)
tree10027f336435511475e392454359edea8e25895d /third_party/rust/url/Cargo.toml
parent49ee0794b5d912db1f95dce6eb52d781dc210db5 (diff)
downloadUXP-5f8de423f190bbb79a62f804151bc24824fa32d8.tar
UXP-5f8de423f190bbb79a62f804151bc24824fa32d8.tar.gz
UXP-5f8de423f190bbb79a62f804151bc24824fa32d8.tar.lz
UXP-5f8de423f190bbb79a62f804151bc24824fa32d8.tar.xz
UXP-5f8de423f190bbb79a62f804151bc24824fa32d8.zip
Add m-esr52 at 52.6.0
Diffstat (limited to 'third_party/rust/url/Cargo.toml')
-rw-r--r--third_party/rust/url/Cargo.toml38
1 files changed, 38 insertions, 0 deletions
diff --git a/third_party/rust/url/Cargo.toml b/third_party/rust/url/Cargo.toml
new file mode 100644
index 000000000..c3f4d364b
--- /dev/null
+++ b/third_party/rust/url/Cargo.toml
@@ -0,0 +1,38 @@
+[package]
+
+name = "url"
+version = "1.2.1"
+authors = ["The rust-url developers"]
+
+description = "URL library for Rust, based on the WHATWG URL Standard"
+documentation = "http://servo.github.io/rust-url/url/index.html"
+repository = "https://github.com/servo/rust-url"
+readme = "README.md"
+keywords = ["url", "parser"]
+license = "MIT/Apache-2.0"
+
+[[test]]
+name = "unit"
+
+[[test]]
+name = "data"
+harness = false
+
+[lib]
+test = false
+
+[dev-dependencies]
+rustc-test = "0.1"
+rustc-serialize = "0.3"
+
+[features]
+query_encoding = ["encoding"]
+heap_size = ["heapsize"]
+
+[dependencies]
+encoding = {version = "0.2", optional = true}
+heapsize = {version = ">=0.1.1, <0.4", optional = true}
+idna = { version = "0.1.0", path = "./idna" }
+matches = "0.1"
+rustc-serialize = {version = "0.3", optional = true}
+serde = {version = ">=0.6.1, <0.9", optional = true}