summaryrefslogtreecommitdiffstats
path: root/ipc/chromium/src/third_party/libevent/sample/Makefile.am
diff options
context:
space:
mode:
authorMatt A. Tobin <mattatobin@localhost.localdomain>2018-02-02 04:16:08 -0500
committerMatt A. Tobin <mattatobin@localhost.localdomain>2018-02-02 04:16:08 -0500
commit5f8de423f190bbb79a62f804151bc24824fa32d8 (patch)
tree10027f336435511475e392454359edea8e25895d /ipc/chromium/src/third_party/libevent/sample/Makefile.am
parent49ee0794b5d912db1f95dce6eb52d781dc210db5 (diff)
downloadUXP-5f8de423f190bbb79a62f804151bc24824fa32d8.tar
UXP-5f8de423f190bbb79a62f804151bc24824fa32d8.tar.gz
UXP-5f8de423f190bbb79a62f804151bc24824fa32d8.tar.lz
UXP-5f8de423f190bbb79a62f804151bc24824fa32d8.tar.xz
UXP-5f8de423f190bbb79a62f804151bc24824fa32d8.zip
Add m-esr52 at 52.6.0
Diffstat (limited to 'ipc/chromium/src/third_party/libevent/sample/Makefile.am')
-rw-r--r--ipc/chromium/src/third_party/libevent/sample/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/ipc/chromium/src/third_party/libevent/sample/Makefile.am b/ipc/chromium/src/third_party/libevent/sample/Makefile.am
new file mode 100644
index 000000000..c926f4e6f
--- /dev/null
+++ b/ipc/chromium/src/third_party/libevent/sample/Makefile.am
@@ -0,0 +1,29 @@
+# sample/Makefile.am for libevent
+# Copyright 2000-2007 Niels Provos
+# Copyright 2007-2012 Niels Provos and Nick Mathewson
+#
+# See LICENSE for copying information.
+
+AUTOMAKE_OPTIONS = foreign no-dependencies
+
+LDADD = $(LIBEVENT_GC_SECTIONS) ../libevent.la
+AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/compat -I$(top_srcdir)/include -I../include
+
+noinst_PROGRAMS = event-test time-test signal-test dns-example hello-world http-server
+
+event_test_SOURCES = event-test.c
+time_test_SOURCES = time-test.c
+signal_test_SOURCES = signal-test.c
+dns_example_SOURCES = dns-example.c
+hello_world_SOURCES = hello-world.c
+http_server_SOURCES = http-server.c
+
+if OPENSSL
+noinst_PROGRAMS += le-proxy
+le_proxy_SOURCES = le-proxy.c
+le_proxy_LDADD = $(LDADD) ../libevent_openssl.la -lssl -lcrypto ${OPENSSL_LIBADD}
+endif
+
+verify:
+
+DISTCLEANFILES = *~