summaryrefslogtreecommitdiffstats
path: root/libraries/gui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/gui/CMakeLists.txt')
-rw-r--r--libraries/gui/CMakeLists.txt28
1 files changed, 0 insertions, 28 deletions
diff --git a/libraries/gui/CMakeLists.txt b/libraries/gui/CMakeLists.txt
deleted file mode 100644
index 1551a927..00000000
--- a/libraries/gui/CMakeLists.txt
+++ /dev/null
@@ -1,28 +0,0 @@
-project(MultiMC_logic)
-
-set(GUI_SOURCES
- DesktopServices.h
- DesktopServices.cpp
-
- # Icons
- icons/MMCIcon.h
- icons/MMCIcon.cpp
- icons/IconList.h
- icons/IconList.cpp
-
- SkinUtils.cpp
- SkinUtils.h
-)
-################################ COMPILE ################################
-
-add_library(MultiMC_gui SHARED ${GUI_SOURCES})
-set_target_properties(MultiMC_gui PROPERTIES CXX_VISIBILITY_PRESET hidden VISIBILITY_INLINES_HIDDEN 1)
-
-generate_export_header(MultiMC_gui)
-
-# Link
-target_link_libraries(MultiMC_gui iconfix MultiMC_logic)
-qt5_use_modules(MultiMC_gui Gui)
-
-# Mark and export headers
-target_include_directories(MultiMC_gui PUBLIC "${CMAKE_CURRENT_BINARY_DIR}" "${CMAKE_CURRENT_SOURCE_DIR}")