summaryrefslogtreecommitdiffstats
path: root/api/logic/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'api/logic/CMakeLists.txt')
-rw-r--r--api/logic/CMakeLists.txt26
1 files changed, 15 insertions, 11 deletions
diff --git a/api/logic/CMakeLists.txt b/api/logic/CMakeLists.txt
index 2a73566d..1048e091 100644
--- a/api/logic/CMakeLists.txt
+++ b/api/logic/CMakeLists.txt
@@ -82,21 +82,25 @@ set(PATHMATCHER_SOURCES
set(NET_SOURCES
# network stuffs
+ net/ByteArraySink.h
+ net/ChecksumValidator.h
+ net/Download.cpp
+ net/Download.h
+ net/FileSink.cpp
+ net/FileSink.h
+ net/HttpMetaCache.cpp
+ net/HttpMetaCache.h
+ net/MetaCacheSink.cpp
+ net/MetaCacheSink.h
net/NetAction.h
- net/MD5EtagDownload.h
- net/MD5EtagDownload.cpp
- net/ByteArrayDownload.h
- net/ByteArrayDownload.cpp
- net/CacheDownload.h
- net/CacheDownload.cpp
- net/NetJob.h
net/NetJob.cpp
- net/HttpMetaCache.h
- net/HttpMetaCache.cpp
- net/PasteUpload.h
+ net/NetJob.h
net/PasteUpload.cpp
- net/URLConstants.h
+ net/PasteUpload.h
+ net/Sink.h
net/URLConstants.cpp
+ net/URLConstants.h
+ net/Validator.h
)
# Game launch logic